We have seen gradual improvement across our services over the past hours and are still monitoring until Microsoft flags the issue as fully resolved.
Posted Oct 09, 2025 - 15:52 CEST
Monitoring
Microsoft has identified that there is a large ongoing outage to their global load balancing service. Any status updates on this outage can be followed here: https://azure.status.microsoft/en-us/status
Posted Oct 09, 2025 - 12:18 CEST
Identified
We're experiencing connectivity and Certificate errors for the ChannelEngine web portal and API. The cause of these issues has been identified as a regional outage on Microsoft Azure Frontdoor and have been confirmed by Microsoft. These errors are intermittent, and are mostly observed in Europe. These issues don't affect ChannelEngine synchronization jobs.